]> git.pld-linux.org Git - packages/crossmingw32-libsigc++.git/blame - crossmingw32-libsigc++.spec
- updated to 2.12.0
[packages/crossmingw32-libsigc++.git] / crossmingw32-libsigc++.spec
CommitLineData
1a9246c6
JB
1Summary: The Typesafe Signal Framework for C++ - MinGW32 cross version
2Summary(pl.UTF-8): Środowisko sygnałów z kontrolą typów dla C++ - wersja skrośna dla MinGW32
67b44d4b
JB
3%define realname libsigc++
4Name: crossmingw32-%{realname}
2ce6706a
JB
5Version: 2.12.0
6Release: 1
67b44d4b 7License: LGPL v2.1+
066b4b18 8Group: Development/Libraries
2ce6706a
JB
9Source0: https://download.gnome.org/sources/libsigc++/2.12/%{realname}-%{version}.tar.xz
10# Source0-md5: 943b7aef5d74fbc4f4a3bb67bcfaae02
7cbcae3d 11URL: https://libsigcplusplus.github.io/libsigcplusplus/
dec16728 12BuildRequires: autoconf >= 2.59
951a73e1 13BuildRequires: automake >= 1:1.9
7cbcae3d 14BuildRequires: crossmingw32-gcc-c++ >= 1:4.7
e27607ce 15BuildRequires: libtool >= 2:2.0
dec16728 16BuildRequires: m4
8c977c89 17BuildRequires: mm-common >= 0.9.10
dec16728 18BuildRequires: perl-base
1a9246c6 19BuildRequires: pkgconfig
951a73e1
JB
20BuildRequires: tar >= 1:1.22
21BuildRequires: xz
7cbcae3d 22Requires: crossmingw32-gcc-c++ >= 1:4.7
dec16728 23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%define no_install_post_strip 1
bb72a2bc 26%define _enable_debug_packages 0
dec16728 27
28%define target i386-mingw32
29%define target_platform i386-pc-mingw32
dec16728 30
31%define _sysprefix /usr
32%define _prefix %{_sysprefix}/%{target}
6986ab9d
JB
33%define _libdir %{_prefix}/lib
34%define _pkgconfigdir %{_prefix}/lib/pkgconfig
066b4b18 35%define _dlldir /usr/share/wine/windows/system
dec16728 36%define __cc %{target}-gcc
37%define __cxx %{target}-g++
7e12b981 38%define __pkgconfig_provides %{nil}
b8988822 39%define __pkgconfig_requires %{nil}
dec16728 40
96d9454a
JB
41%ifnarch %{ix86}
42# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
43%define optflags -O2
44%endif
e27607ce 45# -z options are invalid for mingw linker, most of -f options are Linux-specific
96d9454a 46%define filterout_ld -Wl,-z,.*
79081b3a 47%define filterout_c -f[-a-z0-9=]*
e27607ce 48%define filterout_cxx -f[-a-z0-9=]*
96d9454a 49
dec16728 50%description
51This library implements a full callback system for use in widget
52libraries, abstract interfaces, and general programming. Originally
53part of the Gtk-- widget set, libsigc++ is now a seperate library to
54provide for more general use. It is the most complete library of its
55kind with the ablity to connect an abstract callback to a class
56method, function, or function object. It contains adaptor classes for
57connection of dissimilar callbacks and has an ease of use unmatched by
58other C++ callback libraries.
59
1a9246c6 60This package contains cross MinGW32 version.
708b30c2 61
a0719c45
JR
62%description -l pl.UTF-8
63Ta biblioteka jest implementacją pełnego systemu callbacków do
64używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
65ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
66Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
67przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
68łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
69obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
70callbacków.
dec16728 71
1a9246c6 72Ten pakiet zawiera wersję skrośną MinGW32.
708b30c2 73
066b4b18 74%package static
1a9246c6
JB
75Summary: Static libsigc++ library (cross MinGW32 version)
76Summary(pl.UTF-8): Statyczna biblioteka libsigc++ (wersja skrośna MinGW32)
066b4b18
JB
77Group: Development/Libraries
78Requires: %{name} = %{version}-%{release}
79
80%description static
1a9246c6 81Static libsigc++ library (cross MinGW32 version).
066b4b18
JB
82
83%description static -l pl.UTF-8
1a9246c6 84Statyczna biblioteka libsigc++ (wersja skrośna MinGW32).
066b4b18
JB
85
86%package dll
87Summary: DLL libsigc++ library for Windows
88Summary(pl.UTF-8): Biblioteka DLL libsigc++ dla Windows
89Group: Applications/Emulators
90Requires: wine
91
92%description dll
93DLL libsigc++ library for Windows.
94
95%description dll -l pl.UTF-8
96Biblioteka DLL libsigc++ dla Windows.
97
dec16728 98%prep
67b44d4b 99%setup -q -n %{realname}-%{version}
dec16728 100
101%build
6bea4d77 102mm-common-prepare --copy --force
dec16728 103%{__libtoolize}
1a9246c6 104%{__aclocal} -I build
dec16728 105%{__autoconf}
6bea4d77 106%{__autoheader}
dec16728 107%{__automake}
108%configure \
178e282c 109 --target=%{target} \
110 --host=%{target} \
8c977c89 111 --disable-silent-rules \
178e282c 112 --enable-static
113
8c977c89 114%{__make}
dec16728 115
116%install
117rm -rf $RPM_BUILD_ROOT
118
119%{__make} install \
120 DESTDIR=$RPM_BUILD_ROOT
121
066b4b18
JB
122install -d $RPM_BUILD_ROOT%{_dlldir}
123mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
124
125%if 0%{!?debug:1}
126%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
127%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
128%endif
129
1a9246c6 130%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{devhelp,doc}
066b4b18 131
dec16728 132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%files
136%defattr(644,root,root,755)
2ce6706a 137%doc AUTHORS ChangeLog NEWS README.md
066b4b18
JB
138%{_libdir}/libsigc-2.0.dll.a
139%{_libdir}/libsigc-2.0.la
140%{_libdir}/sigc++-2.0
723599ec 141%{_includedir}/sigc++-2.0
67b44d4b 142%{_pkgconfigdir}/sigc++-2.0.pc
066b4b18
JB
143
144%files static
145%defattr(644,root,root,755)
146%{_libdir}/libsigc-2.0.a
147
148%files dll
149%defattr(644,root,root,755)
150%{_dlldir}/libsigc-2.0-*.dll
This page took 0.168564 seconds and 4 git commands to generate.